Degraded Performance on tidbcloud.com

Incident Report for TiDB Cloud

Resolved

The slower-than-usual response times on tidbcloud.com have been resolved.

Our team has confirmed that the service is operating normally.
Posted Jul 01, 2026 - 08:49 UTC

Investigating

We are currently observing slower-than-usual response times on tidbcloud.com.

Our team is actively investigating the issue and will provide updates as soon as more information becomes available.
Posted Jul 01, 2026 - 05:43 UTC
This incident affected: TiDB Cloud Portal Backend and TiDB Cloud Portal Frontend.